Signs of a torque converter going bad?? - Cherokee SRT8 Forum
WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 05-08-2010, 05:48 PM Thread Starter
Elite Contributing Member
 
eddiefig's Avatar
 
Join Date: May 2007
Location: Woodbridge, NJ
Posts: 2,310
Thanks: 0
Thanked 0 Times in 0 Posts
Signs of a torque converter going bad??

What are the early symptoms? I went to a shop today to do a base dyno run to see where I'm at before doing mods in the new year. While it was doing the run, it got to about 87 MPH and 5500 RPM and all of a sudden the a$$ end drops as if it shifts but it doesn't. The dyno sheet shows in all three runs consistently at the same range that the power drops by about 40 HP and than shoots up about 70. The guy even felt it inside and said it was weird especially with the power drop and peak. The mechanic there said it may be the torque converter going bad. This same "shift" feeling happens in second also at mild throttle. It sounds like it shifts but I didn't shift it. Anyone have an idea? Thanks.

No Jeep for me right now but I still have the respect for it
eddiefig is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 05-08-2010, 06:24 PM Thread Starter
Elite Contributing Member
 
eddiefig's Avatar
 
Join Date: May 2007
Location: Woodbridge, NJ
Posts: 2,310
Thanks: 0
Thanked 0 Times in 0 Posts
I have a video of the run and a pic of the sheet uploading right now. Its weird to see.
eddiefig is offline  
post #3 of 17 (permalink) Old 05-08-2010, 06:40 PM Thread Starter
Elite Contributing Member
 
eddiefig's Avatar
 
Join Date: May 2007
Location: Woodbridge, NJ
Posts: 2,310
Thanks: 0
Thanked 0 Times in 0 Posts
Ok, watch and listen at the 30-32 second mark. The a$$ just drops at 5500 RPM but the RPMs were still climbing as normal. Thing is the power and torque dropped significantly and than jumped back up. Pic shows 3 runs (red, green and blue) lined up and it was consistent. Funny thing is that its also happening at the speed I've been complaining about to the dealer. With paperwork, I hope they'll believe me now.




Last edited by eddiefig; 05-08-2010 at 08:07 PM.
eddiefig is offline  
post #4 of 17 (permalink) Old 05-09-2010, 07:30 AM
Elite Contributing Member
 
pjs1965's Avatar
 
Join Date: May 2009
Location: Long Island, NY
Posts: 4,186
Thanks: 0
Thanked 0 Times in 0 Posts
That's curious. Subscribing to see what comes of this. GL eddie.

Peter J
2009 Brillant Black SRT8
Arrington CAI, Tuned by Hemituner (AJ)


Best Auto Insurance | Auto Protection Today | FREE Trade-In Quote
pjs1965 is offline  
post #5 of 17 (permalink) Old 05-09-2010, 07:02 PM Thread Starter
Elite Contributing Member
 
eddiefig's Avatar
 
Join Date: May 2007
Location: Woodbridge, NJ
Posts: 2,310
Thanks: 0
Thanked 0 Times in 0 Posts
I've been having this issue since I got this thing and the dealer didn't even mention this as a possibility. I can't wait to go there with some solid info and get it looked at. I think I at least should get a new torque converter and a tranny flush. It was so weird how it happened at the exact same speed that I told them it did and the dyno doesn't lie. I would be like a pig in sh*t if that was it. Lol.
eddiefig is offline  
post #6 of 17 (permalink) Old 05-09-2010, 07:09 PM
Elite Contributing Member
 
jim383's Avatar
 
Join Date: Aug 2007
Location: SO CA
Posts: 6,782
Thanks: 11
Thanked 559 Times in 452 Posts
They will tell you it must of been something wrong with the dyno or the way it was hooked up. Tell them you want to make appt with the factory rep to come and drive it. They also may say why was it on a dyno you have to fig there going to look at anyway to keep from fixing it.

2015 JEEP CHEROKEE LIMITED
jim383 is offline  
post #7 of 17 (permalink) Old 05-09-2010, 07:19 PM Thread Starter
Elite Contributing Member
 
eddiefig's Avatar
 
Join Date: May 2007
Location: Woodbridge, NJ
Posts: 2,310
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jim383 View Post
They will tell you it must of been something wrong with the dyno or the way it was hooked up. Tell them you want to make appt with the factory rep to come and drive it. They also may say why was it on a dyno you have to fig there going to look at anyway to keep from fixing it.
I'll just say I had it on the dyno to see if Chrysler was false advertising. Lol. All I have is a CAI and cat-back exhaust both of which are types of mods available by Mopar. Plus, the way it was hooked up should have nothing to do with the computer read out. AND....they were the ones that told me a dyno would be the best and safest way to test it at 90 MPH. The service manager can be pretty reasonable. We're on a first name basis by now and I know he's sick of seeing my face. I'm sick of seeing theirs, too. They wanted me to go to Westbury's dyno but I told them it was too far for me and I can't fit it in my schedule.
eddiefig is offline  
post #8 of 17 (permalink) Old 05-09-2010, 07:39 PM
Premium Lurker
 
af_maineiac's Avatar
 
Join Date: Apr 2008
Location: MD
Posts: 4,234
Thanks: 346
Thanked 697 Times in 423 Posts
This is just a stab in the dark, but do you think this could have anything to do with your CMR tune? I guess the easiest way to find out would be to return it to your stock tune and see if you're having the same issues. Whatever the case, good luck...
.

PWR 440 Hemi Jeep Grand Cherokee SRT8 - SOLD
af_maineiac is offline  
post #9 of 17 (permalink) Old 05-10-2010, 02:06 PM
Junior Member
 
Join Date: May 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Shifty transmission

Quote:
Originally Posted by eddiefig View Post
I have a video of the run and a pic of the sheet uploading right now. Its weird to see.
I am having the same issue with my 06'. I thought it was the fact that I put a new battery and it messed up the Diablo tuner. after calling the people at Diablo,they said dissconnecting the battery had nothing to do with messing up the tuner. I'm new at this so disregard my lack of basic car tuning. Im thinking torque converter after reading the responses to your post! P.S. great srt8 animation,Im thinking t-shirt?
ROBOSRT8 is offline  
post #10 of 17 (permalink) Old 03-30-2011, 05:32 PM
Lifetime Premium Member
 
Join Date: Oct 2010
Location: Pearland, TX
Posts: 888
Thanks: 5
Thanked 89 Times in 68 Posts
Hey eddie did you happen to have that dyno done at a place called Crazy house customs by chance?

2009 JEEP SRT8 FULLY LOADED
BES/HHP 426 STROKER - 6.4L PORT&POLISHED HEADS - STAGE 4 CAM - REAR CROSS MEMBER/ENDLINKSPORT&POLISHED INTAKE MANIFOLD/ARRINGTON 90MM THROTTLE BODY/3000 STALL/INOVATE WIDEBAND/AMERICAN RACING LONGTUBE HEADERS/6K LOWS & FOGS/SOLO/DMH LOW PROFILE E-CUTOUTS/BC COILOVERS/ADDCO SWAYBARS FRONT&REAR/VREDS 275 315/180 THERMOSTAT/LED TAILS/TINTED REAR FOGS/TRINITY/DORMANT BLUE & BLACK POWDER COATING UNDER HOOD AND CALIPERS
==================================================
Tuned by Josh at HHP
552 Max Horsepower - 528 Max Torque

==================================================


Ride4life686 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For those with a Torque Converter LonghornSpencer WK1 Suspension / Driveline Discussion 4 07-24-2009 12:01 PM
torque converter ekaz WK1 General Performance Discussion 2 05-19-2009 07:56 AM
Torque converter? SCAM WK1 General Performance Discussion 3 05-01-2009 08:37 PM
torque converter turtle1678 WK1 General Performance Discussion 0 03-25-2009 08:24 PM
Torque Converter ?? RGC_SRT8 WK1 Suspension / Driveline Discussion 0 06-17-2007 05:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome