Check engine light on....error code P2096...Please help!!! - Cherokee SRT8 Forum
WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 01-24-2009, 12:37 AM Thread Starter
Banned
 
Join Date: Aug 2007
Posts: 657
Thanks: 0
Thanked 0 Times in 0 Posts
Check engine light on....error code P2096...Please help!!!

My check engine light has been on for the last two days....I got the light to go away by clearing the computer with the battery dis-connect method but it came back on. I took it to auto-zone so they could hook up the diagnostic computer and it was throwing the code P2096. What does that mean? My Jeep is stock. I have no idea what it could be, but I did just get my transmission replaced from the dealer if that matters. I just want to know if it is something I can fix myself because the dealer is an hour away from me.
06blackbeast is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 01-24-2009, 07:05 AM
Elite Contributing Member
 
robpp's Avatar
 
Join Date: Sep 2007
Location: Colorado
Posts: 3,987
Thanks: 0
Thanked 0 Times in 0 Posts
P2096-DOWNSTREAM FUEL TRIM SYSTEM 1 LEAN

Set Condition:
If the PCM multiplies short term compensation by long term adaptive as well as a purge fuel multiplier and the result is below a certain value for a calibrated amount of time over two trips, a freeze frame is stored, the MIL illuminates and a trouble code is stored. Two Trip Fault. Three good trips to turn off the MIL.


Possible Causes

EXHAUST LEAK

ENGINE MECHANICAL

1/2 O2 SENSOR

(K141) O2 SENSOR 1/2 SIGNAL CIRCUIT

(K299) O2 1/2 HEATER CONTROL CIRCUIT

(K904) O2 RETURN DOWNSTREAM CIRCUIT

FUEL CONTAMINATION
_____________________________________________

Since you said new trans, i would get under there and check all the wires from the O2s and make sure they didnt pinch or forget to reconnect anything.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by robpp; 01-24-2009 at 09:33 AM.
robpp is offline  
post #3 of 13 (permalink) Old 01-24-2009, 09:53 AM
Elite Contributing Member
 
brianm's Avatar
 
Join Date: Mar 2008
Location: AIRDRIE, SCOTLAND
Posts: 3,086
Thanks: 6
Thanked 18 Times in 13 Posts
jeez rob where do you get all this info lol


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
" am gonna pick a fight "

DEBADGED AND REBADGED , STILLEN HEADLIGHT COVERS , VOLENT CAI , RAM MEDIC HOOD ,,NEFFY WRAPPED INTERIOR,BLACK OPS CARBON FIBER REAR STEP AND FRONT LIP INSERT , MOPAR REAR SPOILER ,BORLA S CATBACK , EBC DRILLED AND SLOTTED ROTORS , VIPER STRIPES ,PAINTED HEADLIGHTS WITH HALOS AND FOG LIGHTS WITH HALOS FROM DC SPECIAL, GLOSS BLACK USA SPEC WHEELS, LOWERED ,TUNED BY JOHAN ,,,,,,TOTALLY UNIQUE IN UK
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
brianm is offline  
post #4 of 13 (permalink) Old 01-24-2009, 09:57 AM
Senior Member
 
hemi.jon's Avatar
 
Join Date: Dec 2008
Location: Punta Gorda, FL
Posts: 361
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to hemi.jon
biranm if you google the error code it comes up.

or you can go here
http://www.obd-codes.com/trouble_codes/


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hemi.jon is offline  
post #5 of 13 (permalink) Old 01-24-2009, 10:07 AM
Elite Contributing Member
 
brianm's Avatar
 
Join Date: Mar 2008
Location: AIRDRIE, SCOTLAND
Posts: 3,086
Thanks: 6
Thanked 18 Times in 13 Posts
Quote:
Originally Posted by hemi.jon View Post
biranm if you google the error code it comes up.

or you can go here
http://www.obd-codes.com/trouble_codes/
thanks mate
brianm is offline  
post #6 of 13 (permalink) Old 01-24-2009, 10:09 AM
Major Contributing Member
 
shorestyle031's Avatar
 
Join Date: Dec 2007
Location: Point Pleasent, NJ
Posts: 1,421
Thanks: 0
Thanked 0 Times in 0 Posts
phil i would go to the dealer for that

08 BMW M Roadster
Sold: 07 SRT8
shorestyle031 is offline  
post #7 of 13 (permalink) Old 01-24-2009, 11:03 AM
Elite Contributing Member
 
robpp's Avatar
 
Join Date: Sep 2007
Location: Colorado
Posts: 3,987
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by brianm View Post
thanks mate
All that gives you is the title of the fault. If you want the probable cause and the steps for finding the issue, they are from the Service Manual. I have a CD version copied to my laptop.

Brian, let me know if you need one.

Rob
robpp is offline  
post #8 of 13 (permalink) Old 01-24-2009, 12:31 PM Thread Starter
Banned
 
Join Date: Aug 2007
Posts: 657
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks robpp! Here is what I was thinking....I bet they had to unbolt the exhaust to replace the tranny and when they re-installed it, they didnt line it up correctly. I am saying this because I just noticed an interesting rattle coming from my exhaust which sounds like an exhaust leak to me....I'll check it out today.
06blackbeast is offline  
post #9 of 13 (permalink) Old 01-24-2009, 12:44 PM
Elite Contributing Member
 
CentralTexHemi's Avatar
 
Join Date: Apr 2007
Location: Texas
Posts: 10,785
Thanks: 31
Thanked 62 Times in 24 Posts
Does it sound like a helicopter or choppy also look for any exhaust soot (black) around the exhaust connections

2007 SRT8 Jeep GC-Sold 7/28/2011
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 Porsche Cayenne S
2012 Shelby GT500-10.6 @ 128
2014 Porsche Cayenne GTS (on way)
CentralTexHemi is offline  
post #10 of 13 (permalink) Old 01-25-2009, 12:44 AM Thread Starter
Banned
 
Join Date: Aug 2007
Posts: 657
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks Tex! Yeah, it was a choppy sound.

I did figure out the problem...... I was under the jeep checking all of the exhaust connections when one of my o2 sensors was extremely loose! This was definatley the problem. It looked like they had just put it in place and forgot to tighten it because all the other ones were fine. Air was definately getting in there and I could wiggle it with the lightest touch. Also, they cut the factory tie strap that held the o2 sensor wire up high and away from the heat of the pipes and didn't put a new one on! I could see the old tie strap that had been cut still on there. The wire was just dangling there about half an inch above the pipe, I was surprised it hadn't melted yet. That is some real heat-resistant rubber insulation they have over those wires! So I used my own tie strap and cleaned up the wiring. Also the dealer forgot to tighten the bolts all the way where the stock muffler hooks up to the flanges. After all this, I went over everything under the jeep around the transmission with a fine tooth comb. Other than what's mentioned above, everything else was fine under the jeep and looked good. I have since then reset the CEL and it has not come back on and the exhaust leak noise has disappeared. I'll tell you what though, mechanics at dealers need to slooooow down and quit doing everything so rushed!
06blackbeast is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light Aaron WK1 Troubleshooting / Problems Discussion / Dealer Service 14 05-19-2011 08:57 PM
Check engine light and shifting issue. Cell Mass WK1 SRT8 General Discussion 3 01-23-2009 04:53 PM
Check Engine Light B&G PhillyJeep WK1 SRT8 General Discussion 6 12-16-2007 11:29 PM
Break-in Procedures AaronC WK1 SRT8 General Discussion 2 08-05-2006 08:03 AM
BAD GAS?? --- check engine flashing upon acceleration SRSSRT8 WK1 Troubleshooting / Problems Discussion / Dealer Service 6 05-23-2006 03:07 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome