quick oil question - Cherokee SRT8 Forum
WK1 SRT8 General Discussion This section contains general discussion relating to the Jeep Grand Cherokee SRT8.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 01-10-2013, 05:14 PM Thread Starter
Major Contributing Member
 
Btelander's Avatar
 
Join Date: Jul 2011
Location: Des Moines Iowa
Posts: 1,380
Thanks: 114
Thanked 176 Times in 137 Posts
quick oil question

I had my forged motor installed 4 months ago and I have driven 2k miles since. I have now had to add my 3rd quart of mobile 1. I understand thats it normal to have to add more oil after a rebuild but is 3 quarts normal in 2k miles?

2009 BRILLIANT BLACK JEEP SRT8-HHP Forged 6.1 / Stage II Cam / Vortech / STAGE 6 FMIC KIT/ 17% OD pulley/ OBX Headers / Magnaflow Catback-reso delete/Stage 6 Tips /PTCM/SHR/ FTI/ ATI / R1 Concepts Crossed/Slotted / Eibach Springs / 6k HID lows/fogs / Rear LED's / TLS Rear Harness / PML Diff cover/ Bwoody Endlinks, Panhard Bar, Control Arms/ QA1/ Motivos 275/315 W/ Nitto NT 05 275/315 S

2015 WHITE JEEP OVERLAND
2008 BLACK ESCALADE EXT

Brian
Btelander is online now  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 01-10-2013, 06:16 PM
Premium Whore (Lifetime)
 
StangSlayerMA's Avatar
 
Join Date: May 2009
Location: Massachusetts
Posts: 3,065
Thanks: 388
Thanked 551 Times in 395 Posts
Garage
Quote:
Originally Posted by Btelander View Post
I had my forged motor installed 4 months ago and I have driven 2k miles since. I have now had to add my 3rd quart of mobile 1. I understand thats it normal to have to add more oil after a rebuild but is 3 quarts normal in 2k miles?

I don't think you're suppossed to use synthetic oil during the break-in period. When I had ordered a PWR 426, Andy told me to use traditional oil for the first 3000-5000 miles.....then switch to synthetic.

StangSlayerMA is offline  
The Following User Says Thank You to StangSlayerMA For This Useful Post:
BJB (01-10-2013)
post #3 of 14 (permalink) Old 01-10-2013, 06:25 PM
Super Moderator
 
cmn1's Avatar
 
Join Date: Mar 2006
Location: Addison, IL
Posts: 10,605
Thanks: 1,054
Thanked 1,875 Times in 1,363 Posts
Garage
Quote:
Originally Posted by Btelander View Post
I had my forged motor installed 4 months ago and I have driven 2k miles since. I have now had to add my 3rd quart of mobile 1. I understand thats it normal to have to add more oil after a rebuild but is 3 quarts normal in 2k miles?
I went through a lot of oil myself. I am almost to 3300 miles on mine and the missing oil has greatly subsided

Quote:
Originally Posted by StangSlayerMA View Post
I don't think you're suppossed to use synthetic oil during the break-in period. When I had ordered a PWR 426, Andy told me to use traditional oil for the first 3000-5000 miles.....then switch to synthetic.
Andy told me the same thing. Break in oil for 300 miles and then 3000 miles on regular oil and then whatever you want afterward.

Chad (06 Inferno Red GC SRT8) PWR 6.3L, PWR Apache Heads, Stage6 76 mm Turbo, Stage6 Fuel Pump, SHR NAG1-HTCr, PI 2400 TQ Converter, ATI Flex Plate, BC Coil Overs, Wilwood TC6R calipers, Kooks Headers, Mopar exhaust, MM 85mm T-body, Jerseyboy CMR, Bwoody Sway Links, R1 Concepts F Slot & Dimp, R StopTech Pads, Earls Trans Cooler, TLS Rear Fog Harness
cmn1 is offline  
The Following User Says Thank You to cmn1 For This Useful Post:
Knuckles (01-10-2013)
post #4 of 14 (permalink) Old 01-11-2013, 07:03 PM
Senior Contributing Member
 
Join Date: Apr 2006
Location: Florence, N.J.
Posts: 575
Thanks: 0
Thanked 12 Times in 5 Posts
Quote:
Originally Posted by Btelander View Post
I had my forged motor installed 4 months ago and I have driven 2k miles since. I have now had to add my 3rd quart of mobile 1. I understand thats it normal to have to add more oil after a rebuild but is 3 quarts normal in 2k miles?
1st. You should not use Mobil1 to break in the motor, use a light weight detergent oil otherwise the rings won't seat properly and you will get blow by. 2nd. Loose fit engines will use oil, remember this and always keep an eye on the Oil. Check for leaks, have the Vehicle put on a lift and check for leaks with the motor running. Why did you Forge the motor are you going to Supercharge it?


Jack
dodgeboy16 is offline  
post #5 of 14 (permalink) Old 01-11-2013, 07:40 PM Thread Starter
Major Contributing Member
 
Btelander's Avatar
 
Join Date: Jul 2011
Location: Des Moines Iowa
Posts: 1,380
Thanks: 114
Thanked 176 Times in 137 Posts
Quote:
Originally Posted by dodgeboy16 View Post
1st. You should not use Mobil1 to break in the motor, use a light weight detergent oil otherwise the rings won't seat properly and you will get blow by. 2nd. Loose fit engines will use oil, remember this and always keep an eye on the Oil. Check for leaks, have the Vehicle put on a lift and check for leaks with the motor running. Why did you Forge the motor are you going to Supercharge it?


Jack
Yep, im supercharged. Blew my first motor. Josh at hhp never mentioned any of this. Also, I had an hhp dealer in minn install the reinstall the blower and motor.

Last edited by Btelander; 01-11-2013 at 07:43 PM.
Btelander is online now  
post #6 of 14 (permalink) Old 01-11-2013, 08:06 PM Thread Starter
Major Contributing Member
 
Btelander's Avatar
 
Join Date: Jul 2011
Location: Des Moines Iowa
Posts: 1,380
Thanks: 114
Thanked 176 Times in 137 Posts
I just did some brief reading on blow by. I really hope this is not the case. I even told josh that the engine installer added 0-40 mobile and he didnt say anything. I guess ill have to talk to him on moday. What are some warning signs? Will he be able to tell in a log? let me remind you that im in des moines iowa 4 hours from where my engine was installed.
Btelander is online now  
post #7 of 14 (permalink) Old 01-11-2013, 08:42 PM
Super Moderator
 
cmn1's Avatar
 
Join Date: Mar 2006
Location: Addison, IL
Posts: 10,605
Thanks: 1,054
Thanked 1,875 Times in 1,363 Posts
Garage
I don't even use 0-40 any more. My motor uses 10w30. So you may want to check
cmn1 is offline  
post #8 of 14 (permalink) Old 01-11-2013, 08:47 PM Thread Starter
Major Contributing Member
 
Btelander's Avatar
 
Join Date: Jul 2011
Location: Des Moines Iowa
Posts: 1,380
Thanks: 114
Thanked 176 Times in 137 Posts
Quote:
Originally Posted by cmn1 View Post
I don't even use 0-40 any more. My motor uses 10w30. So you may want to check
are u running full sythetic?
Btelander is online now  
post #9 of 14 (permalink) Old 01-11-2013, 08:50 PM
Super Moderator
 
cmn1's Avatar
 
Join Date: Mar 2006
Location: Addison, IL
Posts: 10,605
Thanks: 1,054
Thanked 1,875 Times in 1,363 Posts
Garage
Quote:
Originally Posted by Btelander View Post
are u running full synthetic?
Not yet. Have 200 more miles to go till I hit my 3300. Real close though and then I will be running synthetic. Going to be sending a sample to Blackstone to see how the motor is wearing.
cmn1 is offline  
post #10 of 14 (permalink) Old 01-14-2013, 08:56 AM Thread Starter
Major Contributing Member
 
Btelander's Avatar
 
Join Date: Jul 2011
Location: Des Moines Iowa
Posts: 1,380
Thanks: 114
Thanked 176 Times in 137 Posts
Update-if anyone cares. Spoke to the installed and he ran 10-30 on the dyno. Changed the oil to Mobile 1 0-40.

Does this sound ok?
Btelander is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
quick question!! dashti01 Off-Topic Discussion 0 09-30-2012 08:57 PM
quick question please help Hussain90 WK1 General Performance Discussion 6 08-29-2011 01:01 AM
Quick Question..... urntfstenuf WK1 Suspension / Driveline Discussion 0 03-12-2011 01:01 PM
quick question?? SRT8-DOUGLAS JR WK1 Audio/Video/Nav/UConnect/Electronics 3 11-04-2010 05:13 PM
quick question srt4me WK1 SRT8 General Discussion 3 07-08-2008 08:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome