Misfire on cylinder 8 - spark plugs no gap - Cherokee SRT8 Forum
WK2 SRT8 General Performance Discussion Discuss WK2 SRT8 general performance enhancing modifications here.

 11Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 26 (permalink) Old 03-07-2017, 12:22 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: Tulsa, Oklahoma
Posts: 7
Thanks: 3
Thanked 0 Times in 0 Posts
Unhappy Misfire on cylinder 8 - spark plugs no gap

Ok - Here goes! So I got stuck behind someone who was driving a little slower then I liked. Tried to pass the guy and suddenly he wasn't having it. Needless to say I stomped on the gas and SHOULD HAVE blown his doors off. But that's not what happened my SRT let me down. Wound up with check engine light coming on for a misfire on cylinder 8. No problem right, just pop some new plugs in and its good to go. Except not so much. I'm not sure about the plug order on my jeep, but the two plugs on the driver side closest to the firewall had no gap left. They were smashed pretty good. Now my poor SRT has a new ticking/tapping sound from that cylinder. It still runs good hasn't slowed it down. Just doesn't sound right and I'm afraid to drive it. To make matters worse my warranty expired in Jan. Anyone have any ideas what it could be?
Momisfast is offline  
Sponsored Links
Advertisement
 
post #2 of 26 (permalink) Old 03-07-2017, 01:11 PM
Contributing Member
 
PITTZ's Avatar
 
Join Date: Nov 2010
Location: New Market, Md
Posts: 4,219
Thanks: 771
Thanked 1,781 Times in 1,141 Posts
That would be cylinder #7. So you did already replaced those plugs with new ones?

Only good thing to come out of this would be a bigger and better motor.
Passmg2 likes this.

Maggie w/ 2.9 Pulley and 80lb injectors.
Kooks Headers
B&B Exhaust
PWR 224 Cam
Ported Heads
Meth Injection
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PITTZ is offline  
The Following User Says Thank You to PITTZ For This Useful Post:
Momisfast (03-07-2017)
post #3 of 26 (permalink) Old 03-07-2017, 02:17 PM
Lifetime Premium Member
 
Jfra's Avatar
 
Join Date: Oct 2012
Location: North Carolina
Posts: 4,232
Thanks: 3,772
Thanked 1,802 Times in 1,202 Posts
Garage
Sounds like you may have some ring-land failure. Hopefully not but smashed spark plugs doesn't bode well.


Sent from my iPhone using Tapatalk

Procharger F1a, Paramount Conquerer, Wavetrac, LED's, rear fogs activated, bwoody links, Borla S, Tooned, R1 cross drilled, slotted and cryo treated stoptechs and lowered on Eibachs sitting on FR 22"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New block waiting for some love
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jfra is online now  
The Following User Says Thank You to Jfra For This Useful Post:
Momisfast (03-07-2017)
 
post #4 of 26 (permalink) Old 03-07-2017, 02:28 PM
Thread Derailer
 
Passmg2's Avatar
 
Join Date: Jun 2015
Location: Waterdown, Ontario
Posts: 3,783
Thanks: 5,109
Thanked 1,244 Times in 866 Posts
You have ring failure. I lived that myself. Who knows how long it will run like that. I take it your Jeep isn't stock?
Poorboy likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

PB 10.998 @ 126.8
2015 Jeep GC SRT
Passmg2 is offline  
The Following User Says Thank You to Passmg2 For This Useful Post:
Momisfast (03-07-2017)
post #5 of 26 (permalink) Old 03-07-2017, 03:04 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: Tulsa, Oklahoma
Posts: 7
Thanks: 3
Thanked 0 Times in 0 Posts
Yep, replaced all the plugs. I don't have any major mods. Just the basics, catch can, Hennessey cold air induction, and diablo trinity tune. Wouldn't have thought trying to pass a guy on the highway would cause such an issue. These things are made to go fast, I'm a little disappointed.
Momisfast is offline  
post #6 of 26 (permalink) Old 03-07-2017, 03:19 PM
Thread Derailer
 
Passmg2's Avatar
 
Join Date: Jun 2015
Location: Waterdown, Ontario
Posts: 3,783
Thanks: 5,109
Thanked 1,244 Times in 866 Posts
Wow, how many miles on it? First one I've heard of let go that's basically stock, do you drive it hard? Sorry to hear, I know how much it sucked when I did it... although Pittz nailed it - here's a chance to do up the new motor.
Passmg2 is offline  
post #7 of 26 (permalink) Old 03-07-2017, 06:35 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: Tulsa, Oklahoma
Posts: 7
Thanks: 3
Thanked 0 Times in 0 Posts
Misfire on cylinder 8 - spark plugs no gap

It only has about 65,000 miles on it, nothing excessive. I've never taken it to the track or street raced with it (boring I know). It's my baby and I take it easy most of the time, but I do count on the power being there when I need it. Engine upgrade sounds fantastic and expensive. Finding a trust worthy mechanic who knows what they are doing is my next problem.
Momisfast is offline  
post #8 of 26 (permalink) Old 03-07-2017, 06:38 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Location: Tulsa, Oklahoma
Posts: 7
Thanks: 3
Thanked 0 Times in 0 Posts
Oh and I did buy it preowned from a car dealer. So I'm sure it was used and abused.
Momisfast is offline  
post #9 of 26 (permalink) Old 03-07-2017, 07:28 PM
Thread Derailer
 
Passmg2's Avatar
 
Join Date: Jun 2015
Location: Waterdown, Ontario
Posts: 3,783
Thanks: 5,109
Thanked 1,244 Times in 866 Posts
How long have you had it? Any chance the previous owner had a blower on it and caused the damage, then put it back to stock and you inherited the problem? Like I said, I've never heard of a stock motor letting go and it only has 65,000 miles on it. Maybe some of the more experienced guys will jump in with their opinion but from what you're saying it shouldn't have let go. Signs that it was used and abused?

Last edited by Passmg2; 03-07-2017 at 07:29 PM.
Passmg2 is offline  
post #10 of 26 (permalink) Old 03-07-2017, 07:37 PM
Senior Member
 
Sillyhp's Avatar
 
Join Date: Nov 2016
Posts: 468
Thanks: 0
Thanked 82 Times in 74 Posts
Thats what i thought previos blower on it. Or someone messing around with the fuel tables or timing or something. Ive never heard of this without some boost but I guess it could happen. Is it under warranty? And I think u should build her now. Just in case u wanna put a couple hair dryers on there! Sorry brotha good luck
Passmg2 likes this.
Sillyhp is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Spark Plug Gap TutsSRT8 WK1 General Performance Discussion 6 04-01-2014 07:31 PM
Spark plug gap, what should it be at?... S/C bzz srt8 WK1 General Performance Discussion 12 12-06-2012 09:14 PM
Spark Plugs - Heat Range and Gap GlobeWarmer WK1 General Performance Discussion 2 01-12-2012 01:58 PM
Cylinder 4 misfire la77amx WK1 Troubleshooting / Problems Discussion / Dealer Service 11 11-07-2011 08:36 PM
Spark Plug Gap??? NYCSRT WK1 Troubleshooting / Problems Discussion / Dealer Service 5 03-22-2009 06:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome