What did I do?! - Cherokee SRT8 Forum
WK2 SRT8 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your WK2 SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 02-26-2013, 11:47 AM Thread Starter
the..opinionated youngin'
 
cthcarter's Avatar
 
Join Date: Dec 2011
Location: Atlanta, GA
Posts: 496
Thanks: 67
Thanked 62 Times in 48 Posts
Send a message via Skype™ to cthcarter
What did I do?!

Alright so if you read my post in the exhaust section for WK2 you will see my problem will the valves in the exhaust rattling like crazy!

On the way to run some errands my engine light comes on. I'm worried sick about it at that point. I check my trinity and he shows P0303. Misfire in cylinder 3.

What the hell did we do that made this all happen? I am so worried right now as I don't have tons of money to fix stuff. The only thing I can think of is go back to the exhaust shop and have them put everything back on! There goes 400 dollars out the window...

Someone please help. This is driving me insane. I am freaking out

2010 Nissan GT-R. Switzer P600, H&R Springs, AMS Matte CF hood, CF lip, CF spoiler.

Supercharged 2012 SRT8 - SOLD
cthcarter is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 02-26-2013, 11:53 AM
Speed Junkie
 
Brooksie's Avatar
 
Join Date: Nov 2011
Location: Atlanta
Posts: 480
Thanks: 70
Thanked 115 Times in 75 Posts
I read your post in the exhaust section I would make sure that shop did not remove valves . I would make sure. Many have removed them but I left mine just to avoid this type of headache and fuel mileage

2016 GC SRT Granite
2014 GC SRT Brilliant Black-Sold
2012 GCSRT8 Brilliant Black-Sold

Brooksie is offline  
post #3 of 25 (permalink) Old 02-26-2013, 11:54 AM Thread Starter
the..opinionated youngin'
 
cthcarter's Avatar
 
Join Date: Dec 2011
Location: Atlanta, GA
Posts: 496
Thanks: 67
Thanked 62 Times in 48 Posts
Send a message via Skype™ to cthcarter
I'm sure he didn't. I watched him do the whole thing. We talked about what to do with them and he said research it and then we will figure out what to do with them.
The valves are for sure there.
cthcarter is offline  
post #4 of 25 (permalink) Old 02-26-2013, 11:58 AM
Speed Junkie
 
Brooksie's Avatar
 
Join Date: Nov 2011
Location: Atlanta
Posts: 480
Thanks: 70
Thanked 115 Times in 75 Posts
Not knowing exactly your setup maybe the install caused one or more of the valves to be in a bind and be stuck either open or shut, you can check their movement from underneath make sure they move freely
Brooksie is offline  
post #5 of 25 (permalink) Old 02-26-2013, 12:30 PM Thread Starter
the..opinionated youngin'
 
cthcarter's Avatar
 
Join Date: Dec 2011
Location: Atlanta, GA
Posts: 496
Thanks: 67
Thanked 62 Times in 48 Posts
Send a message via Skype™ to cthcarter
I was playing with them before we took her off the lift. No problems. They were moving fine and were not stuck. The rattle is horrible and I am getting the check engine light sound more and more. Guessing the cylinder is misfiring more now. I'm getting worried.
cthcarter is offline  
post #6 of 25 (permalink) Old 02-26-2013, 12:37 PM
Premium Reformed Member
 
tugboatchad's Avatar
 
Join Date: Jan 2010
Location: The great NorthWet (Seattle)
Posts: 3,494
Thanks: 2,384
Thanked 939 Times in 647 Posts
What did I do?!

Do you know how to check your spark plugs? If so, pull the plugs on cyl. #3 and see what they look like? It'll be the second cylinder from the front on the drivers side.


Sent from AutoGuide.com App

Troy built 2010 Jeep SRT8, Dings Racing forged 392 stroker, boost reference return style fuel system, Mondello heads & manifold, ARH 1 7/8" LT's, Off road midpipe, stock cat back exhaust, ATI 17% OD pulley, Stage 6 2-step, Fluidyne radiator, PP built Nag1, remote transmission cooler, PP Dom. TC., 6,500 PTCM, Wavetrac rear LSD.
tugboatchad is offline  
post #7 of 25 (permalink) Old 02-26-2013, 12:38 PM
Speed Junkie
 
Brooksie's Avatar
 
Join Date: Nov 2011
Location: Atlanta
Posts: 480
Thanks: 70
Thanked 115 Times in 75 Posts
Maybe not the valves rattling? Maybe something else, missed weld ,something loose ,exhaust leak?
Brooksie is offline  
post #8 of 25 (permalink) Old 02-26-2013, 12:45 PM Thread Starter
the..opinionated youngin'
 
cthcarter's Avatar
 
Join Date: Dec 2011
Location: Atlanta, GA
Posts: 496
Thanks: 67
Thanked 62 Times in 48 Posts
Send a message via Skype™ to cthcarter
Quote:
Originally Posted by tugboatchad View Post
Do you know how to check your spark plugs? If so, pull the plugs on cyl. #3 and see what they look like? It'll be the second cylinder from the front on the drivers side.


Sent from AutoGuide.com App
I do not know how put I will look it up and do it when I get home.

Quote:
Originally Posted by Brooksie View Post
Maybe not the valves rattling? Maybe something else, missed weld ,something loose ,exhaust leak?
I checked for leaks and missed welds. Did not see anything.

Anyone else chime in? I really would like to get this sorted out.
cthcarter is offline  
post #9 of 25 (permalink) Old 02-26-2013, 12:56 PM
Speed Junkie
 
Brooksie's Avatar
 
Join Date: Nov 2011
Location: Atlanta
Posts: 480
Thanks: 70
Thanked 115 Times in 75 Posts
Does the check engine light come on when Eco mode turns on? Drive in sport or track to turn off Eco and see if you still get the light.
Brooksie is offline  
post #10 of 25 (permalink) Old 02-26-2013, 12:58 PM Thread Starter
the..opinionated youngin'
 
cthcarter's Avatar
 
Join Date: Dec 2011
Location: Atlanta, GA
Posts: 496
Thanks: 67
Thanked 62 Times in 48 Posts
Send a message via Skype™ to cthcarter
Quote:
Originally Posted by Brooksie View Post
Does the check engine light come on when Eco mode turns on? Drive in sport or track to turn off Eco and see if you still get the light.
I'll try it in just a few.
cthcarter is offline  
The Following User Says Thank You to cthcarter For This Useful Post:
wikkid (02-27-2013)
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome