Transmission Issues - Page 2 - Cherokee SRT8 Forum
WK2 SRT8 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your WK2 SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 54 (permalink) Old 05-07-2012, 05:07 PM
Senior Member
 
ehaser1's Avatar
 
Join Date: Dec 2006
Posts: 124
Thanks: 10
Thanked 22 Times in 14 Posts
Mine does this as well. Horribly. It feels like the transfer case but I'm not 100% certain. I can actually hear it the worst going from reverse to drive but that is expected. The problem is that i can now hear it when the car starts to down shift as I approach a stop in auto mode. I'm going to take it to my dealer to have it diagnosed. It's under warranty so I'm not really concerned unless it starts missing gears altogether.
ehaser1 is offline  
Sponsored Links
Advertisement
 
post #12 of 54 (permalink) Old 05-07-2012, 06:56 PM
Senior Member
 
Join Date: Sep 2010
Location: Durham NC
Posts: 303
Thanks: 24
Thanked 22 Times in 18 Posts
Try disconnecting the transfer case motor and then attempt the shifts?


Sent from my Autoguide iPhone app
digi is offline  
post #13 of 54 (permalink) Old 05-08-2012, 06:30 AM
Member
 
Join Date: Mar 2012
Posts: 66
Thanks: 1
Thanked 2 Times in 2 Posts
I carefully listened to mine last night and couldn't hear any clunking. I tested in the garage so the noise would have been amplified. I have only had my SRT for a couple days but for me the only time I have heard a clunking noise was going from 1st to 2nd gear and this has only happened a couple of times.
smbsocal is offline  
post #14 of 54 (permalink) Old 05-08-2012, 06:42 AM Thread Starter
Senior Member
 
Kadonny's Avatar
 
Join Date: Oct 2011
Location: Pennsylvania
Posts: 468
Thanks: 43
Thanked 50 Times in 46 Posts
Quote:
Originally Posted by ehaser1 View Post
Mine does this as well. Horribly. It feels like the transfer case but I'm not 100% certain. I can actually hear it the worst going from reverse to drive but that is expected. The problem is that i can now hear it when the car starts to down shift as I approach a stop in auto mode. I'm going to take it to my dealer to have it diagnosed. It's under warranty so I'm not really concerned unless it starts missing gears altogether.
Bingo! Keep us posted if the dealer finds anything. You can hear it sometimes too when in Sport or Auto and you are manually shifting (downshifting) at stop signs/lights. It's normally 3rd to 2nd gear for me.

PS: My shift hesitation/miss seems to have disappeared for now even though the dealer said they did nothing. I do bet however that they disconnected the battery and perhaps this reset the transmission and put it back to learn mode. Who knows.

2012 Jeep GC SRT8 WK2
Deep Cherry Red
Lux Group II, SRT Audio, Pano Roof
20% Tint, De-badged doors, Billet catch can, SRT front badge
Previous car CTS-V sedan

Last edited by Kadonny; 05-08-2012 at 06:44 AM.
Kadonny is offline  
post #15 of 54 (permalink) Old 06-07-2012, 01:14 PM Thread Starter
Senior Member
 
Kadonny's Avatar
 
Join Date: Oct 2011
Location: Pennsylvania
Posts: 468
Thanks: 43
Thanked 50 Times in 46 Posts
Ok, update on what I thought was the transmission. It's not the transmission, it's a throttle issue.

Had it happen 3 times recently and the past two were the worst. Doing about 45 mph on a country road, usually going uphill I give throttle to keep speed going up the hill. The problem is the engine does not recognize the throttle. The Jeep doesn't stall, it just doesn't take the increased throttle. Did it this morning, I slowly pushed the pedal down to accelerate with nothing happening. This lasted about 3 seconds when I finally almost got my foot to the floor the transmission does a real hard downshift and the throttle kicks in to jolt me back in my seat. From there it drives normally.

So, what the hell can this be? I'm taking it in again to fix the windshield, so for sure I'm going to be harping on this issue. Unacceptable.
Kadonny is offline  
post #16 of 54 (permalink) Old 06-22-2012, 08:42 PM
Premium Member
 
Join Date: Jun 2012
Location: Rockland County, NY
Posts: 112
Thanks: 2
Thanked 27 Times in 11 Posts
Send a message via Skype™ to rivetpro
I get a weird downshift when going from 2nd to first. Almost like its going from 2 to 1. Then back to 2 again. Is that common?
rivetpro is offline  
post #17 of 54 (permalink) Old 06-25-2012, 12:37 PM
Junior Member
 
Join Date: Apr 2012
Posts: 9
Thanks: 0
Thanked 2 Times in 2 Posts
My 2012 clunks every time I shift into drive or reverse. Also does it most of the time when rolling braking to a stop and it downshifts from 3rd to 2nd. It's consistant and does it whether hot or cold....
thompstl1 is offline  
post #18 of 54 (permalink) Old 06-25-2012, 12:46 PM
Elite Contributing Member
 
meeper's Avatar
 
Join Date: Mar 2009
Location: West Grove, PA
Posts: 3,129
Thanks: 27
Thanked 355 Times in 295 Posts
i dunno why chrysler could think they would be able to use a transmission thats only rated for 428 ft lbs on a big heavy car with an engine making 470 ft lbs..... duRRRR
meeper is online now  
post #19 of 54 (permalink) Old 06-25-2012, 01:45 PM
The Traveler
 
Mongoose9400's Avatar
 
Join Date: Dec 2010
Location: Dallas, TX
Posts: 5,254
Thanks: 477
Thanked 676 Times in 522 Posts
Quote:
Originally Posted by meeper View Post
i dunno why chrysler could think they would be able to use a transmission thats only rated for 428 ft lbs on a big heavy car with an engine making 470 ft lbs..... duRRRR
I'm sure they've done something to make it work. Also, it's warrantied for 100k miles. So they must feel confident about it. But, the SRT engineers have said its near it's maximum torque input.


Sent from my iPhone 4S

Zac
2012 WK2 SRT8 Mineral Gray | BT Catch Can | BT Underhood Goodies | Painted Engine Bay | Bwoody CAI | Custom Washer Setup | Shaved Jeep/Color Matched Liftgate Brow| Chrome Delete | Debadge-ReBadged | 5% Tint All Around | 78% Windshield Tint | Passport 9500ix | TLS Rear Fogs | 5k HID Fogs | 6k LED Running Lights | 8k Bi-Xenon | 6K LED Plate Lights | 6k Interior LED Swap | Borla ATAK | WK1 Borla Reso Swap | Matching eBrake Pedal | Trinity | Modified DS 93 Tune
SOLD 2007 Silver Jeep SRT8

Mongoose9400 is offline  
post #20 of 54 (permalink) Old 06-25-2012, 06:21 PM
Elite Contributing Member
 
BuilderBill's Avatar
 
Join Date: Nov 2006
Location: Charlotte, North Carolina
Posts: 5,781
Thanks: 235
Thanked 881 Times in 395 Posts
Quote:
Originally Posted by meeper View Post
i dunno why chrysler could think they would be able to use a transmission thats only rated for 428 ft lbs on a big heavy car with an engine making 470 ft lbs..... duRRRR
All about torque management.
Bill
BuilderBill is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission issues teacher54 WK1 Troubleshooting / Problems Discussion / Dealer Service 3 01-14-2012 06:45 AM
TPMS issues and replacement issues brianm WK1 Troubleshooting / Problems Discussion / Dealer Service 2 12-14-2010 05:18 AM
T/C, Transmission, Braking Issues? VETE8R WK1 Troubleshooting / Problems Discussion / Dealer Service 4 12-03-2009 08:08 AM
transmission issues frenchified WK1 Troubleshooting / Problems Discussion / Dealer Service 16 12-16-2008 04:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome